Workflow Execution Status Available in the Workflow Report
Incident Report for BetterCloud
Resolved
We have completed our investigation of the issue, identified the root cause, and remediated the underlying issue, which impacted a subset of customer Workflow instances executed between 1:30AM EST May 25th and 7:00PM EST May 29th and resulted in an accurate workflow action status in the instance's Workflow Report but an inaccurate Workflow status in the Workflow Activity Feed.

Customers may see duplicate instance IDs of impacted Workflows with the original targets appear in the Workflow Activity Feed.

We apologize for any inconvenience this issue may have caused. If you have any questions, please contact Support: support@bettercloud.com.
Posted May 31, 2023 - 11:27 EDT
Update
We are continuing to investigate an issue impacting a subset of customers' workflow instances. The issue is resulting in the display of an inaccurate workflow status in the Workflow Activity Feed for workflows executed on or since May 25, 2023.

Customers can review the accurate status of their workflow instance's actions by navigating to Workflows > Activity Feed > and clicking into a specific Workflow instance ID to view the Action execution history. Impacted Workflows will have an "incomplete" status next to Actions that were not successfully completed.

We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com.
Posted May 26, 2023 - 18:11 EDT
Investigating
We are currently investigating an issue impacting a subset of customers’ workflow instances. The issue is resulting the display of an inaccurate workflow status in the Workflow Activity Feed for workflows executed in the last 20 hours.

Customers can review the accurate status of their workflow instance's actions by navigating to Workflows > Activity Feed > and clicking into a specific Workflow instance ID to view the Action execution history. Impacted Workflows will have an "incomplete" status next to Actions that were not successfully completed.

We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com.
Posted May 25, 2023 - 21:50 EDT
This incident affected: BetterCloud (Workflow Activity Feed).