Okta Workflow Delay
Incident Report for BetterCloud
Resolved
We have released the fix to prevent further Okta events from becoming delayed at 1:03 PM EST. We are currently processing the backlog of delayed events from before the fix was released. Okta events after the fix was introduced at 1:03 PM EST are processing within expected time frames. Thank you for your patience. If you have any questions or see further issues, please contact the Support Team at support@bettercloud.com
Posted Nov 12, 2021 - 17:30 EST
Update
The additional fix to resolve the delayed Okta events continues to be tested. We will provide another update here by 5PM EST Today (11/12/21). Thank you for your patience. If you have any questions, please contact the BetterCloud support team at support@bettercloud.com
Posted Nov 12, 2021 - 09:30 EST
Update
We have an additional change in testing that we expect to further prevent Okta directory events from becoming delayed. We will provide another by 10 AM EST on 11/12/21. Thank you for your patience, if you have any questions, please contact the BetterCloud support team at support@bettercloud.com
Posted Nov 11, 2021 - 17:11 EST
Update
We are continuing to monitor our Okta syncs for any further issues. We will provide updates here until this incident is resolved. If you have any questions, please contact the BetterCloud Support Team.
Posted Nov 05, 2021 - 20:41 EDT
Update
We are continuing to monitor our Okta syncs after yesterday’s changes. We will continue to provide updates here until we are confident this issue is resolved. If you have any questions, please contact the BetterCloud Support Team.
Posted Nov 04, 2021 - 13:03 EDT
Update
We have released several fixes that are improving Okta sync performance. We are continuing to monitor and will provide updates until this incident is resolved. If you have any questions, please contact the BetterCloud Support Team.
Posted Nov 03, 2021 - 16:58 EDT
Monitoring
A subset of changes have been implemented and we are monitoring the results. Additional changes are planned to help ensure this issue is fixed. We will continue to provide updates here. If you have any questions, please contact the BetterCloud Support Team.
Posted Nov 03, 2021 - 11:07 EDT
Update
We have planned several changes that we expect to improve this issue and will continue to provide updates here as we work towards a resolution. If you have any questions, please contact the BetterCloud Support Team.
Posted Nov 02, 2021 - 18:25 EDT
Identified
We have identified the root cause of an issue causing some Okta updates to sync in at a delay. As a result, Workflows configured to trigger based on these updates may also be delayed. We will provide updates here as we work towards a resolution. Until then, affected workflows can be run on-demand as a workaround. If you have any questions, please contact the BetterCloud Support Team.
Posted Nov 02, 2021 - 11:48 EDT
This incident affected: BetterCloud (Directory, Workflows) and Integrations (Okta).