Alerts
Incident Report for BetterCloud
Resolved
This incident has been resolved. Users should once again be able to access the Alerts interface. Please contact support@bettercloud.com with any questions or concerns.
Posted Aug 20, 2020 - 17:14 EDT
Identified
We have identified the root cause of an issue that is preventing users from accessing the Alerts interface. We are working towards a fix and will provide an update here soon. Please contact support@bettercloud.com with any questions or concerns.
Posted Aug 20, 2020 - 16:36 EDT
This incident affected: BetterCloud (Alerts).