Audit Logs Outage
Incident Report for BetterCloud
Resolved
The Audit Logs page has been fixed and should be loading as expected. No Audit Logs were lost during this incident. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 19, 2019 - 17:37 EDT
Investigating
We are currently investigating an issue that is preventing Audit Logs from loading. We apologize for any inconvenience and will provide another update as soon as we have more information. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 19, 2019 - 17:15 EDT
This incident affected: BetterCloud (Audit Logs).