Delay in Workflows and Workflow Actions

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Jul 29, 2022 - 09:10 EDT

Identified

We are investigating an issue that is causing Workflows and Workflow Actions to be delayed in execution. We are working to resolve this issue as soon as possible and will provide updates here as we work towards a resolution. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Jul 28, 2022 - 16:22 EDT
This incident affected: User Automation (Workflows).