BetterCloud For G Suite Inaccessible
Incident Report for BetterCloud
Resolved
BetterCloud for G Suite is stable and should be accessible to all users as expected. If you have any questions, please contact support@bettercloud.com
Posted Jul 26, 2019 - 16:44 EDT
Monitoring
We have taken action to fix the issue that was preventing users from accessing BetterCloud for G Suite. We are monitoring to ensure that it is stable.
Posted Jul 26, 2019 - 13:25 EDT
Investigating
We are investigating the root cause of an issue that is preventing users from accessing BetterCloud for G Suite (g.bettercloud.com). We will provide another update as soon as we have more information. If you have any questions, please contact support@bettercloud.com
Posted Jul 26, 2019 - 13:11 EDT
This incident affected: BetterCloud for G Suite.