User Creation in BetterCloud for G Suite
Incident Report for BetterCloud
Resolved
The issue causing intermittent errors when creating users in g.bettercloud.com has been resolved. We appreciate your patience and apologize for any inconvenience this has caused. If you have any questions, please reach out to our Support team at support@bettercloud.com.
Posted May 12, 2022 - 09:36 EDT
Investigating
We are aware of and investigating an issue that is causing errors when users are created in BetterCloud for G Suite (g.bettercloud.com). Click here for proposed workarounds and more information. If you have any questions or concerns, please contact our Support team.
Posted Apr 15, 2022 - 11:19 EDT
This incident affected: BetterCloud for G Suite.