Cannot Access BetterCloud

Incident Report for BetterCloud

Resolved

Google's engineering team has resolved the issue affecting BetterCloud services. Customers can now access BetterCloud and should no longer experience performance issues. If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 12, 2025 - 17:25 EDT

Identified

After initial investigation, the scope of this issue may lead to users experiencing degraded performance across all BetterCloud products. We have identified the root cause of the issue to be: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW#2c2sBHWU84yPDJ8y1ar4. If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 12, 2025 - 16:05 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 15:00 EDT

Investigating

We are currently investigating an issue that is preventing users from accessing BetterCloud. We apologize for the inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 12, 2025 - 14:23 EDT
This incident affected: User Automation (Core Services, Alerts, Directory, Files, Workflows, Privileges, Audit Logs, Platform API, Applications, Dashboard, Data Protection, Global Search, Workflow Activity Feed, Content Scanning) and Spend Optimization, File Governance, Google Administration.