Suspended Integrations
Incident Report for BetterCloud
Resolved
All affected Google Drive asset syncs have been restored. This incident has been resolved. Please contact support@bettercloud.com with any questions or concerns.
Posted Feb 26, 2021 - 10:51 EST
Update
We are continuing efforts to fully resolve Google Drive asset syncs after Google Integrations were reconnected. Additionally, we have deployed a fix for the separate, ongoing Alerts issue, and can confirm that all go-forward Alerts are triggering Workflows correctly as of 5:00 AM ET. Queued Alerts from during this incident are currently processing and will take some time to complete. Workflows utilizing Alerts reliant on Google Drive file updates may not trigger immediately. Still, you can continue to run Workflows On-Demand as needed. We appreciate your continued patience. Please contact support@bettercloud.com with any questions or concerns.
Posted Feb 25, 2021 - 10:54 EST
Update
We have completed reconnecting all suspended Google Integrations. Additional efforts are still underway to resolve Google Drive asset syncs for those impacted. While we continue to settle a separate, ongoing Alerts issue, we can confirm that these legacy events are not impacted by the incident and continue to function as Alerts normally. Workflows utilizing Alerts events not listed in the linked article, or those reliant on Google Drive sync events, may not trigger immediately upon reconnection, but you can continue to run Workflows On-Demand as needed. We appreciate your patience through this incident. Please contact support@bettercloud.com with any questions or concerns.
Posted Feb 24, 2021 - 17:09 EST
Update
We continue our efforts to automatically reconnect suspended Google Integrations. Users can confirm their Google integrations' connection status and manually reconnect from the Installed tab of the Integration Center. Due to a separate ongoing issue with Alerts, some Workflows may not trigger immediately upon reconnection, but can be run On-Demand. Please contact support@bettercloud.com with any questions or concerns.
Posted Feb 24, 2021 - 13:24 EST
Update
We have identified the root cause of the issue resulting in Google Integration suspensions that also temporarily prevented some users from accessing g.bettercloud.com. Access to g.bettercloud.com has been restored. Efforts are underway to automatically reconnect suspended Google Integrations in bulk. However, customers may optionally choose to reconnect any suspended integrations directly from the Integration Center. We will continue to provide updates here as we work to resolve this issue. Please contact support@bettercloud.com with any questions or concerns.
Posted Feb 24, 2021 - 04:59 EST
Identified
We have identified the root cause of an issue that is causing some integrations to become suspended unexpectedly and temporarily prevented some users from accessing the g.bettercloud.com interface. We are working on a remediation plan.
Posted Feb 24, 2021 - 03:59 EST
This incident affected: BetterCloud (Core Services, Files) and BetterCloud for G Suite.