Workflow Delays
Incident Report for BetterCloud
Resolved
Though the AWS incident is still ongoing, we have been monitoring BetterCloud Workflows all afternoon to ensure stability. We are going to tentatively mark this incident as "Resolved", but will continue to monitor BetterCloud Workflows until the AWS incident is fully resolved and update our status page if needed. If you experience any Workflow delays, please contact our Support team at support@bettercloud.com.
Posted Dec 22, 2021 - 17:42 EST
Monitoring
We have resolved all Workflow delays stemming from the AWS outage and will continue to monitor our system until the AWS outage is completely resolved (for addition information regarding the AWS outage, please visit: https://status.aws.amazon.com/).
If you have any questions, please contact the support team at support@bettercloud.com.
Posted Dec 22, 2021 - 13:16 EST
Identified
We have identified that the current AWS outage affecting Slack is causing Workflow delays in app.bettercloud.com (for additional information please visit: https://status.aws.amazon.com/). Customers may experience delays in Workflows completing until this issue is resolved by AWS.

If you have any questions, please contact the support team at support@bettercloud.com
Posted Dec 22, 2021 - 11:58 EST
This incident affected: BetterCloud (Workflows).