Spend Optimization Performance

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 14:30 EDT

Monitoring

The intermittent delays in the Spend Optimization UI have subsided. We are monitoring to ensure continued normal performance. If you have any questions, please contact our Support Team.
Posted Jul 17, 2025 - 12:37 EDT

Investigating

We are currently investigating an issue that may cause intermittent delays in the Spend Optimization UI. Updates will be provided here as we work towards a fix. If you have any questions, please contact our Support Team.
Posted Jul 17, 2025 - 10:56 EDT
This incident affected: Spend Optimization.