Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2024 - 07:00 EST
Update
The maintenance window for BetterCloud's Spend Optimization functionality (aka: Track) is being rescheduled to Tuesday, December 3rd 2024 from 7:00AM to 9:00AM ET
Posted Nov 27, 2024 - 18:30 EST
Update
The maintenance window for BetterCloud's Spend Optimization functionality (aka: Track) is being rescheduled to Thursday, November 28th 2024 from 7:00AM to 9:00AM ET
Posted Nov 25, 2024 - 16:36 EST
Scheduled
BetterCloud's Spend Optimization functionality (aka: Track) is scheduled to undergo routine maintenance on Tuesday, November 26th 2024 from 7:00AM to 9:00AM ET.
Within this window, customers may experience the following behavior in BetterCloud's Spend Optimization functionality on trackapp.bettercloud.com: - Unable to login or use the UI - Possible inconsistencies while viewing UI elements - Errors initiating certain flows from the UI