Google Directory Syncs Delays
Incident Report for BetterCloud
Resolved
We have resolved the issue that was affecting Google directory syncs for some customers. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 30, 2023 - 17:26 EDT
Monitoring
We have taken action to fix the issue that may have been affecting Google directory syncs for some customers and are continuing to monitor its progress. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 30, 2023 - 12:10 EDT
Update
We are currently investigating an issue that may be intermittently affecting Google directory syncs for some customers. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 29, 2023 - 15:05 EDT
Investigating
We are currently investigating an issue that may be intermittently affecting Google directory syncs for some customers. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 29, 2023 - 15:02 EDT
This incident affected: BetterCloud (Directory) and Integrations (Dropbox, Google).