Workflow email notifications are not sending

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 09:25 EDT

Update

We have implemented a fix for the workflow notification issue and are monitoring to ensure it is resolved. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Apr 27, 2026 - 09:38 EDT

Monitoring

We are investigating an issue that is preventing Workflow email notifications from sending for a subset of customers. We are working to resolve this issue as soon as possible and will provide updates here as we work towards a resolution. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Apr 24, 2026 - 17:11 EDT
This incident affected: User Automation (Workflows).