BetterCloud Outage
Incident Report for BetterCloud
Resolved
Google reported the outage as resolved for all users and access to BetterCloud should be fully restored. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted 9 months ago. Jul 17, 2018 - 16:31 EDT
Monitoring
The login issue was caused by a Google Cloud Platform outage and they reported it as being resolved for a majority of users: https://status.cloud.google.com/

It appears that functionality has been restored and we will continue to monitor the situation. Thank you for your patience.
Posted 9 months ago. Jul 17, 2018 - 16:03 EDT
Investigating
We are currently investigating an issue that is preventing users from accessing BetterCloud. We will provide another update as soon as we have more information. If you have any questions, please contact Support: support@bettercloud.com
Posted 9 months ago. Jul 17, 2018 - 15:20 EDT
This incident affected: BetterCloud (Core Services) and BetterCloud for G Suite.