Workflow Actions Delayed
Incident Report for BetterCloud
Resolved
We have resolved the issue causing Workflow Actions to be delayed in executing for some customers. We apologize for any inconvenience this issue may have caused. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Sep 20, 2022 - 15:59 EDT
Identified
We have identified the issue causing Workflow Actions to be delayed in executing for some customers. We are working a fix to resolve this issue as soon as possible, and will provide updates here as we work towards a resolution. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Sep 20, 2022 - 15:26 EDT
Investigating
We are currently investigating an issue that is causing Workflow Actions delays for some customers. We are working to resolve this issue as soon as possible and will provide updates here as we work towards a resolution. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Sep 20, 2022 - 14:41 EDT
This incident affected: BetterCloud (Workflows).