Suspended O365 Integrations
Incident Report for BetterCloud
Resolved
This incident has been resolved.
Posted Jan 10, 2023 - 16:05 EST
Monitoring
We are remediating the issue resulting in the suspension of a limited number of user’s O365 integration. All impacted customers have received email notifications and are advised to reconnect their integrations. We will provide further updates as they become available. Please contact support@bettercloud.com with if you have any questions.
Posted Dec 22, 2022 - 21:29 EST
Investigating
We have received reports indicating that some O365 integrations may be disconnecting unexpectedly. We are currently investigating the issue. We will provide further updates as more details become available. Please contact support@bettercloud.com with any questions or concerns.
Posted Dec 22, 2022 - 13:20 EST
This incident affected: BetterCloud (Core Services) and Integrations (Office 365).