File Ingestion Delay

Incident Report for BetterCloud

Resolved

We have resolved the issue causing delays ingesting files for a subset of customers. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Feb 25, 2025 - 17:35 EST

Investigating

We are currently investigating an issue causing delays ingesting Files for a subset of customers. Affected customers may experience delays in Files appearing/updating in the UI, as well as delays triggering File based Automations. If you have any questions, feel free to reach out our Support Team by emailing support@bettercloud.com.
Posted Feb 25, 2025 - 15:21 EST
This incident affected: User Automation (Alerts, Files, Data Protection).