Data Protection UI Outage
Incident Report for BetterCloud
Resolved
We have resolved the issue that was the UI portion of the Data Protection section in app.bettercloud.com, and everything should be back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 05, 2022 - 12:27 EDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2022 - 17:26 EDT
Investigating
We are currently investigating an issue that is affecting the UI portion of the Data Protection section in app.bettercloud.com. Please note that the workflows and alerts are continuing to perform as expected. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 04, 2022 - 15:13 EDT
This incident affected: BetterCloud (Data Protection).