Cannot Access BetterCloud
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing users from accessing BetterCloud. If you have any questions, please contact Support: support@bettercloud.com
Posted Dec 05, 2019 - 18:44 EST
Investigating
We are currently investigating an issue that is preventing users from accessing BetterCloud. We apologize for the inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Dec 05, 2019 - 18:23 EST
This incident affected: BetterCloud (Core Services).