Slack Outage

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 09:15 EST

Investigating

We are currently investigating the potential impact of an ongoing Slack outage. Users may experience delays with Slack directory syncs, failing Slack actions, and connecting Slack integrations. We will provide updates here as more information becomes available. If you have any questions, please contact our Support Team.
Posted Feb 26, 2025 - 13:39 EST
This incident affected: Integrations (Slack).