Ingestion Delays

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 14:32 EDT

Monitoring

Some functionality may be delayed as a result of a temporary Google Cloud Platform outage. We are monitoring outage status and we are processing the backlog of delayed events. We will provide another update when the delay has been resolved. If you have any questions, please contact our Support Team.
Posted Sep 26, 2025 - 12:29 EDT
This incident affected: User Automation (Alerts, Directory, Files, Workflows, Applications, Data Protection).