Workflow delays and Workflow manage inconsistancy
Incident Report for BetterCloud
Resolved
We have monitored the system overnight and Workflows triggered via the Platform API and Custom Triggers remain stable. The Workflow Builder and Manager page remain stable as well.

We are moving this incident to a "Resolved" state. If you have any questions, please contact Support by reaching out to support@bettercloud.com
Posted Aug 17, 2022 - 13:45 EDT
Monitoring
We have taken action to fix the issue. Workflows triggered via the Platform API and Custom Triggers are triggering normally and the workflow builder and manage pages are loads properly. We are continuing to monitor the performance to ensure that everything is back to normal. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 16, 2022 - 16:08 EDT
Investigating
We are currently investigating an issue that is resulting in an intermittent failure to load that has a limited impacted on the the workflow builder and manage page. Workflows triggered via the Platform API and Custom Triggers may be delayed. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 16, 2022 - 12:40 EDT
This incident affected: BetterCloud (Workflows, Platform API).