Directory Updates Delayed
Incident Report for BetterCloud
Resolved
G Suite directory updates are no longer delayed. Google began reporting multiple G Suite service issues at approximately 12:01 am EST 3/4/20 after our investigations revealed this as the probable root cause, resulting in our escalation to them. Google reported system-wide resolution at approx. 2:42 am 3/4/20 and we can confirm G Suite directory updates were no longer delayed and operating normally by 4:02 am EST 3/4/20 within BetterCloud. On behalf of our valued partner, we apologize for this disruption. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 04, 2020 - 08:43 EST
Identified
We have identified the root cause of the directory delay. User and Group updates for Okta, Dropbox, Slack, and Office 365 are no longer delayed and should be processing as expected.

G Suite directory updates remain delayed but will sync at least every 24 hours until the issue is resolved. We apologize for any inconvenience and will provide another update tomorrow, Wednesday, March 4. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 04, 2020 - 00:16 EST
Update
We are continuing to investigate the issue that is causing directory updates to be delayed. We will provide another update as soon as more information becomes available. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 03, 2020 - 22:43 EST
Investigating
We are currently investigating an issue that is causing user and group updates to be delayed for Google, Okta, Dropbox, Slack, and Office 365. New users/groups and updates to existing users/groups will appear in the Directory later than usual. Alerts and Workflows set to trigger based on those updates are delayed as well. We will continue to provide updates in this space. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 03, 2020 - 21:42 EST
This incident affected: BetterCloud (Directory).